View Issue Details

IDProjectCategoryView StatusLast Update
0001363RackTablesIPv4/IPv6/SLBpublic2018-07-07 19:17
ReportersolicsAssigned Toinfrastation 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.20.8 
Target VersionFixed in Version 
Summary0001363: nat rules
Description1. nat rules are only available for tcp/udp and not other protocols (esp, gre, icmp, etc)
2. rules should accept port ranges in case of UDP/TCP or icmp types in case of icmp
3. sometimes defining only the inbound interface on the router/server is not enough in defining the nat rule, a source ip prefix might be needed. rephrasing a bit: nat on external ip address to internal ip addresses ONLY for certain source ip addresses

the current nat rules are also available on inbound direction. what about outbound ?
TagsNo tags attached.

Activities

infrastation

infrastation

2018-07-07 19:17

administrator   ~0003799

I have to close this request because I do not have the time and motivation to implement it well. NAT support in RackTables is basic, this is a known fact. There are solutions out there (Linux/FreeBSD kernels and beyond) that allow to implement advanced NAT. If anybody wants to be able to document these in RackTables fully they would have to work on this feature themselves.

Issue History

Date Modified Username Field Change
2014-12-04 19:57 solics New Issue
2014-12-04 19:57 solics Status new => assigned
2014-12-04 19:57 solics Assigned To => andriyanov
2014-12-05 11:49 andriyanov Assigned To andriyanov => infrastation
2018-07-07 19:17 infrastation Status assigned => closed
2018-07-07 19:17 infrastation Resolution open => won't fix
2018-07-07 19:17 infrastation Note Added: 0003799