View Issue Details

IDProjectCategoryView StatusLast Update
0001657RackTablesdefaultpublic2016-07-14 10:43
Reportermjdelapena 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSUbuntu server OS Version16.04
Product Version0.20.11 
Target Version0.20.12Fixed in Version0.20.12 
Summary0001657: whenever i try to add a device to my racks i get this
DescriptionPdo exception: PDOException

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'racktables.VLANSwitch' doesn't exist (42S02)
at file /var/www/html/racktables/wwwroot/inc/database.php, line 4058

/var/www/html/racktables/wwwroot/inc/database.php:4058 execute(Array
(
)
)
/var/www/html/racktables/wwwroot/inc/database.php:465 usePreparedSelectBlade('SELECT RackObject.id, RackObject.name, RackObject.label, RackObject.asset_no, RackObject.objtype_id, (SELECT MIN(rack_id) FROM RackSpace WHERE object_id = RackObject.id) as rack_id, (SELECT MIN(parent_entity_id) FROM EntityLink WHERE child_entity_type='object' AND child_entity_id = RackObject.id AND parent_entity_type = 'rack') as rack_id_2, (SELECT MIN(parent_entity_id) FROM EntityLink WHERE child_entity_type='object' AND child_entity_id = RackObject.id AND parent_entity_type = 'object') as container_id, (SELECT name FROM RackObject WHERE id = container_id) as container_name, (SELECT objtype_id FROM RackObject WHERE id = container_id) as container_objtype_id, RackObject.has_problems, RackObject.comment, (SELECT COUNT(*) FROM Port WHERE object_id = RackObject.id) as nports, (SELECT domain_id FROM VLANSwitch WHERE object_id = id LIMIT 1) as 8021q_domain_id, (SELECT template_id FROM VLANSwitch WHERE object_id = id LIMIT 1) as 8021q_template_id FROM RackObject ORDER BY RackObject.name', Array
(
)
)
/var/www/html/racktables/wwwroot/inc/functions.php:1866 listCells('object', NULL)
/var/www/html/racktables/wwwroot/inc/interface.php:2372 applyCellFilter('object', Array
(
    [tagidlist] => Array
        (
        )

    [tnamelist] => Array
        (
        )

    [pnamelist] => Array
        (
        )

    [negatedlist] => Array
        (
        )

    [andor] => and
    [text] =>
    [extratext] =>
    [expression] => Array
        (
        )

    [urlextra] =>
    [is_empty] => 1
)
)
/var/www/html/racktables/wwwroot/index.php:35 renderDepot(NULL)
Error info:

Array
(
    [0] => 42S02
    [1] => 1146
    [2] => Table 'racktables.VLANSwitch' doesn't exist
)
Parameters:

GET

page depot
POST

COOKIE

PHPSESSID 83imurpvbeq5c174tg07el7037
Steps To Reproducei dont know how to reproduce this
TagsNo tags attached.

Relationships

duplicate of 0001647 closedinfrastation Installations fails at step 5 of 7 

Activities

infrastation

2016-07-14 10:43

administrator   ~0003369

RackTables 0.20.11 does not work on Ubuntu 16.04. This includes the installer failing to complete the installation and displaying error messages. The next stable release should have this bug fixed.

Issue History

Date Modified Username Field Change
2016-07-13 21:23 mjdelapena New Issue
2016-07-14 10:43 infrastation Note Added: 0003369
2016-07-14 10:43 infrastation Priority immediate => normal
2016-07-14 10:43 infrastation Status new => closed
2016-07-14 10:43 infrastation Resolution open => duplicate
2016-07-14 10:43 infrastation Fixed in Version => 0.20.12
2016-07-14 10:43 infrastation Target Version => 0.20.12
2016-07-14 10:43 infrastation Relationship added duplicate of 0001647