View Issue Details

IDProjectCategoryView StatusLast Update
0001743RackTablesdefaultpublic2017-05-12 15:32
ReporterkissgAssigned Toinfrastation 
PrioritylowSeverityfeatureReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0001743: More expiration dates
DescriptionWishlist item:

We need several expiration dates recorded in the database. Most of them are software license related.
Yes, I can set up new [T] attributes for servers, but their expiry is not reported on index.php?page=reports&tab=warranty.
Currently there are three expirations hardcoded into interface.php:renderExpirations().
A new, more general data model is required.
TagsNo tags attached.

Activities

infrastation

infrastation

2017-03-04 15:22

administrator   ~0003583

Last edited: 2017-03-04 15:23

View 3 revisions

In the current RackTables code the renderExpirations() function uses the global $expirations array. The default value assigned to that array results in what you see in the report by default but the contents of the array can be amended or replaced in a local plug-in.

kissg

kissg

2017-03-16 14:21

reporter   ~0003591

Unfortunately there is no way to upgrade to the current version until issue 0001733 is solved. :-(
infrastation

infrastation

2017-05-12 15:32

administrator   ~0003613

RackTables 0.20.13 is out, it should have resolved bug 1733 so you can now enjoy the feature you need, which is available since release 0.20.12. Closing.

Issue History

Date Modified Username Field Change
2017-03-04 11:20 kissg New Issue
2017-03-04 15:22 infrastation Note Added: 0003583
2017-03-04 15:22 infrastation Note Edited: 0003583 View Revisions
2017-03-04 15:23 infrastation Note Edited: 0003583 View Revisions
2017-03-16 14:21 kissg Note Added: 0003591
2017-05-12 15:32 infrastation Assigned To => infrastation
2017-05-12 15:32 infrastation Status new => closed
2017-05-12 15:32 infrastation Resolution open => no change required
2017-05-12 15:32 infrastation Note Added: 0003613