View Issue Details

IDProjectCategoryView StatusLast Update
1861RackTablesdefaultpublic2018-11-04 23:47
ReporterdjrzulfAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.20.14 
Target VersionFixed in Version 
Summary1861: Custom port problem with logout
DescriptionWhen you run server on other port than 80 or 443, there is problem with logout.
Patch included.
Additional Information--- interface.php.orig 2018-11-02 21:05:10.780030989 +0100
+++ interface.php 2018-11-02 21:03:53.863472264 +0100
@@ -90,7 +90,7 @@
        // add a trailing slash if the installation resides in a subdirectory
        if ($dirname != '/')
                $dirname .= '/';
- printf ('http%s://logout@%s%s?logout', $https, $_SERVER['SERVER_NAME'], $dirname);
+ printf ('http%s://logout@%s%s%s?logout', $https, $_SERVER['SERVER_NAME'], $port, $dirname);
 }

 $quick_links = NULL; // you can override this in your local.php, but first initialize it with getConfiguredQuickLinks()
TagsNo tags attached.

Relationships

duplicate of 496 closedinfrastation logout did not work as expected 

Activities

infrastation

infrastation

2018-11-04 23:47

administrator   ~0003853

RackTables 0.21.0 incorporates a bug fix for this exact problem (commit 73d1e58).

Issue History

Date Modified Username Field Change
2018-11-02 21:08 djrzulf New Issue
2018-11-04 23:44 infrastation Relationship added duplicate of 496
2018-11-04 23:47 infrastation Status new => closed
2018-11-04 23:47 infrastation Resolution open => duplicate
2018-11-04 23:47 infrastation Note Added: 0003853