View Issue Details

IDProjectCategoryView StatusLast Update
0001721RackTablesdefaultpublic2017-02-20 11:00
Reportersavino 
Assigned Toinfrastation 
PrioritynormalSeverityminorReproducibilityN/A
Status assignedResolutionreopened 
Product Version 
Target Version0.20.12Fixed in Version0.20.12 
Summary0001721: Support for New Switch and Router Models
DescriptionHi Developer,

First I want to thank you for such a wonderful tool/application. I am running RackTables 0.20.11. I have a request.
I will be glad if support for the following switches and routers are added:

1. Cisco ISR4431
2. Cisco ISR4451
3. Cisco ME-3600X
4. Cisco ASR920
5. Cisco ASR1002

Regards,
TagsNo tags attached.

Relationships

Activities

infrastation

2017-02-08 15:26

administrator   ~0003531

1. Cisco ISR4431 -- This already was in the list (key 2629).
2. Cisco ISR4451 -- This already was in the list (key 2630).
3. Cisco ME-3600X -- This stands for two models, those have been added (keys 2663 and 2664).
4. Cisco ASR920 -- This stands for one model, that has been added (key 2574).
5. Cisco ASR1002 -- This already was in the list (key 717).

Done in git commit 4c272b9.

savino

2017-02-13 09:41

reporter   ~0003547

Hi Infrastation,

Thanks for adding support for the devices mentioned in this thread. There are issues I am faced with and hope you can help address them.
 
1. When I add devices of these types (Cisco ISR4431, ISR4451, ME-3600X, ASR920, ASR1002), the "Live Port" and "Live CDP" tabs are not available.

2. I do not see IOS dictionary keys for the following:
   a) ISR 4431 & 4451
      Cisco IOS XE Software, Version 03.13.02.S
      Cisco IOS Software, Version 15.4(3)S2

    b) ASR 1002
        Cisco IOS XE Software, Version 03.14.01.S
        Cisco IOS Software, Version 15.5(1)S1

    c) ASR 920
        Cisco IOS XE Software, Version 03.15.00.S
        Cisco IOS Software, Version 15.5(2)S
       
3. The ASRs 1002 and 920 also do not have the "SNMP sync" tab available.

4. When I add additional interface module to a device, racktables don't seem to detect it

5. The ASR 1002 and 920 are routers. I am wondering why you have them placed under network security.

Again many thanks. I will be glad if you can help address these issue.

Regards,
      

infrastation

2017-02-14 12:30

administrator   ~0003557

1. This is something you would have to configure, please see http://wiki.racktables.org/index.php/Gateways
2. Commit 7787755 adds missing items for routers. For network security this yet remains to be done.
3. Those devices are not supported by this feature at the moment, please see http://wiki.racktables.org/index.php/FAQ
4. Yes, this would be a great feature but nobody has implemented it yet. That said, there is no claim about its existence.
5. ASR 1002 was added in 2008 (see commit d473900) specifically as a network security device. This was a response to a ticket that no longer exists so the best explanation as to why it was done in this exact way is that at that time Cisco said ASR 1000 series was a security appliance rather than a router. Cisco ASR 920 used the same type because you had requested it together with ASR 1002. Commit 7787755 amends the recently added ASR 920 to be a router, this is consistent with what Cisco shows on their web-site today.

savino

2017-02-14 16:49

reporter   ~0003559

Infrastation,

Thanks. I have define in my secret.php file as seen below.

function terminal_settings ($cell, $params)
{
        $params[0]['protocol'] = 'telnet';
        $params[0]['username'] = 'test';
        $params[0]['password'] = 'test';
        $params[0]['timeout'] = 60;
        $racktables_gwdir = 'var/www/html/racktables/gateways/telnet';
        $racktables_gwdir = 'var/www/html/racktables/gateways/netcat';
}

I am able to telnet into other devices ( eg. Cisco 4506, cisco 3945, cisco 2960, etc ) and "Live Port & Live CDP" tabs are available. But they are not available for the device listed above in this thread. I will also be glad if you can add support for the SonicWall 3600.

infrastation

2017-02-14 17:16

administrator   ~0003561

Commit caef7e0 makes the changes necessary to recognize IOS 15 on routers as a managed software. This should just work in RackTables 0.20.13 or you can port the changes from git on your own if you prefer. Network security devices are a separate issue as discusses above.

savino

2017-02-19 09:03

reporter   ~0003563

Thanks a lot infrastation. But I can't find RackTables 0.20.13 for download.

infrastation

2017-02-20 11:00

administrator   ~0003565

RackTables 0.20.13 will be released later and this ticket still remains open.

Issue History

Date Modified Username Field Change
2017-01-21 14:05 savino New Issue
2017-02-08 15:26 infrastation Note Added: 0003531
2017-02-08 15:26 infrastation Assigned To => infrastation
2017-02-08 15:26 infrastation Status new => closed
2017-02-08 15:26 infrastation Resolution open => fixed
2017-02-08 15:26 infrastation Fixed in Version => 0.20.12
2017-02-08 15:26 infrastation Target Version => 0.20.12
2017-02-13 09:41 savino Status closed => feedback
2017-02-13 09:41 savino Resolution fixed => reopened
2017-02-13 09:41 savino Note Added: 0003547
2017-02-14 12:30 infrastation Note Added: 0003557
2017-02-14 16:49 savino Note Added: 0003559
2017-02-14 16:49 savino Status feedback => assigned
2017-02-14 17:16 infrastation Note Added: 0003561
2017-02-19 09:03 savino Note Added: 0003563
2017-02-20 11:00 infrastation Note Added: 0003565