RackTables BT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000338RackTablesSNMPpublic2010-05-21 13:352014-12-26 22:58
Reportertylerwagner 
Assigned Toadoom42 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.17.9 
Target Version0.21.0Fixed in Version0.21.0 
Summary0000338: Unknown OID '9.1.283' on Catalyst 6509
DescriptionI have a Cisco Catalyst 6509. SNMP Sync produces this error:

Unknown OID '9.1.283'

Ports are of the form:

interface GigabitEthernet1/1
...
interface GigabitEthernet1/48
interface GigabitEthernet5/1
interface GigabitEthernet5/2

All ports are standalone (no SFP).

Attached is a full SNMP walk.
Additional InformationSWITCH1#show hardware
Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-M), Version 12.2(33)SXH4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport [^]
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Mon 10-Nov-08 08:30 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)S4, RELEASE SOFTWARE (fc1)
....
cisco WS-C6509 (R7000) processor (revision 2.0) with 458720K/65536K bytes of memory.
Processor board ID SCA042100VU
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from s/w reset
3 Virtual Ethernet interfaces
50 Gigabit Ethernet interfaces
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102


Tagsmodular
Attached Filestxt file icon snmpdump.txt [^] (434,087 bytes) 2010-05-21 13:35

- Relationships

-  Notes
(0000085)
tylerwagner (reporter)
2010-05-21 14:55

Correction: Two ports have SFP:

GigabitEthernet5/1 is only an SFP port, and is empty.
GigabitEthernet5/2 is both a gigabit ethernet port (currently used) and an SFP port (currently empty).
(0000086)
infrastation (administrator)
2010-05-24 16:53

To get a list of installed line cards (similar to one of "show module"), it may help to look into 1.3.6.1.2.1.47.1.1.1.1 SNMP OID. With that information it is possible to generate necessary number of ports without checking type of each port. See function generatePortsForCatModule() in trunk for an example.
(0000198)
infrastation (administrator)
2010-12-02 17:02

Modular systems are not currently supported. Can be considered for reopening, when this is necessary code to handle such data. Closing.
(0000546)
adoom42 (administrator)
2012-01-29 06:03

Re-opened this because I'll be adding support for stackable switches.
(0000766)
tylerwagner (reporter)
2012-08-29 12:49

Great. Let me know if you need testing on Catalyst 6500-series.

- Issue History
Date Modified Username Field Change
2010-05-21 13:35 tylerwagner New Issue
2010-05-21 13:35 tylerwagner File Added: snmpdump.txt
2010-05-21 14:55 tylerwagner Note Added: 0000085
2010-05-24 16:53 infrastation Note Added: 0000086
2010-12-02 17:02 infrastation Note Added: 0000198
2010-12-02 17:02 infrastation Assigned To => infrastation
2010-12-02 17:02 infrastation Status new => closed
2010-12-02 17:02 infrastation Resolution open => won't fix
2012-01-29 06:03 adoom42 Note Added: 0000546
2012-01-29 06:03 adoom42 Assigned To infrastation => adoom42
2012-01-29 06:03 adoom42 Status closed => assigned
2012-01-29 06:03 adoom42 Resolution won't fix => reopened
2012-08-29 12:49 tylerwagner Note Added: 0000766
2013-02-24 20:46 adoom42 Sub-category => SNMP-Modular
2013-02-24 20:54 adoom42 Tag Attached: modular
2014-12-26 22:58 adoom42 Status assigned => closed
2014-12-26 22:58 adoom42 Resolution reopened => fixed
2014-12-26 22:58 adoom42 Fixed in Version => 0.21.0
2014-12-26 22:58 adoom42 Target Version => 0.21.0


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker