View Issue Details

IDProjectCategoryView StatusLast Update
1903RackTablesdefaultpublic2019-04-20 14:14
ReporterlegininAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version0.21.2 
Target VersionFixed in Version 
Summary1903: Cannot install plugin for Custom Reports
DescriptionTrying to install plugin for custom reports as I need report as much as possible. Using manual from this link: https://github.com/lrupp/racktables-reports. Steps as follow:

1. I copied the files from the /reports/ folder to /var/www/racktables/html/racktables/plugins/ (using WinSCP)


2. Try to Activate the plugin via the Configuration => Plugins menu. -> The problem is there is no any plugin (except default Cacti and Munin)
Additional InformationI'm not professional in Linux or PHP, just want to use RackTables in my environment to collect server-network devices information.

System: CentOS7
RackTable version: 0.21.2
DB: MariaDB
PHP Version: 7.0
TagsNo tags attached.

Activities

leginin

leginin

2019-04-20 11:14

reporter  

1.PNG (21,326 bytes)
1.PNG (21,326 bytes)
2.PNG (10,104 bytes)
2.PNG (10,104 bytes)
3.PNG (24,740 bytes)
3.PNG (24,740 bytes)
infrastation

infrastation

2019-04-20 14:14

administrator   ~0003923

The reports directory from lrupp/racktables-reports must be in the plugins directory of RackTables.

Issue History

Date Modified Username Field Change
2019-04-20 11:14 leginin New Issue
2019-04-20 11:14 leginin File Added: 1.PNG
2019-04-20 11:14 leginin File Added: 2.PNG
2019-04-20 11:14 leginin File Added: 3.PNG
2019-04-20 14:14 infrastation Status new => closed
2019-04-20 14:14 infrastation Resolution open => no change required
2019-04-20 14:14 infrastation Description Updated View Revisions
2019-04-20 14:14 infrastation Steps to Reproduce Updated View Revisions
2019-04-20 14:14 infrastation Additional Information Updated View Revisions
2019-04-20 14:14 infrastation Note Added: 0003923