View Issue Details

IDProjectCategoryView StatusLast Update
1907RackTablesdefaultpublic2019-05-14 19:36
ReporterapitsosAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.21.2 
Target VersionFixed in Version 
Summary1907: Issue with a WWN address
DescriptionI am trying to add a specific WWN address on a "L2 address" field, under the "Ports" tab of a server and I am getting the following message:
Argument 'l2address' of value '5?:4B:AD:B0:3D:25:CE:00' is invalid (malformed MAC/WWN/IPoIB address).

Please note that this happens when giving this particular address. Other WWN addresses were accepted. I can't see the reason for this to happen.
Steps To Reproduceyou just need to add the specific "5?:4B:AD:B0:3D:25:CE:00" WWN address on a "L2 address" field, under the "Ports" tab of a server
TagsNo tags attached.

Activities

apitsos

apitsos

2019-05-14 16:32

reporter  

RackTables_WWN-address-error_001_2019-05-14.jpg (427,928 bytes)
infrastation

infrastation

2019-05-14 18:29

administrator   ~0003927

The L2 address 5A:4B:AD:B0:3D:25:CE:00 works in my RackTables. On the screenshot the second character of the address looks like ASCII "A", but in the bug description text it looks like "?", so most likely the check fails because it is not ASCII "A" in the first place.
apitsos

apitsos

2019-05-14 19:34

reporter   ~0003929

Oh my God. How stupid am I? I believe the keyboard was turned in Greek language. Please accept my sincere apologies.

I re-typed and it is accepted now.
apitsos

apitsos

2019-05-14 19:36

reporter   ~0003931

The problem was that i typed by mistake a Greek "A" (non-ASCII character) and couldn't realize, as in capitals there is no difference. My stupidity.

Issue History

Date Modified Username Field Change
2019-05-14 16:32 apitsos New Issue
2019-05-14 16:32 apitsos File Added: RackTables_WWN-address-error_001_2019-05-14.jpg
2019-05-14 18:29 infrastation Note Added: 0003927
2019-05-14 19:34 apitsos Note Added: 0003929
2019-05-14 19:36 apitsos Status new => closed
2019-05-14 19:36 apitsos Resolution open => fixed
2019-05-14 19:36 apitsos Note Added: 0003931