View Issue Details

IDProjectCategoryView StatusLast Update
1913RackTablesdefaultpublic2019-07-10 12:30
ReporterkbabiochAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status newResolutionopen 
Product Version0.21.3 
Target VersionFixed in Version 
Summary1913: SUPER privilege required for database upgrade
DescriptionI'm running RackTables in a MySQL cluster with an unprivileged user. The user has all privileges on the database used by RackTables, but no privileges beyond that. When I run the upgrade from 0.21.2 to 0.21.3 I saw an error message during the upgrade process:

ERROR 1419 (HY000): You do not have the SUPER Privilege and Binary Logging is Enabled

This can be resolved with setting the global variable log_bin_trust_function_creators = 1. However it seems odd to me that global modifications are needed (and/or the SUPER privilege). This should not be the case.
TagsNo tags attached.

Activities

infrastation

infrastation

2019-07-10 12:30

administrator   ~0003981

The upgrade from 0.21.2 to 0.21.3 involves one UPDATE and one INSERT, so the message you have seen was likely from the InnoDB check. I can look into this later, could you post exact steps to reproduce meanwhile?

Issue History

Date Modified Username Field Change
2019-07-08 13:37 kbabioch New Issue
2019-07-10 12:30 infrastation Note Added: 0003981