View Issue Details

IDProjectCategoryView StatusLast Update
1927RackTablesdefaultpublic2019-11-11 21:21
ReporterSergey_yamahaAssigned To 
PriorityhighSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product Version0.21.3 
Target VersionFixed in Version 
Summary1927: PDOException
DescriptionI just installed version 20.3 and can't use it. If i try go to rackspaces, I see erorr
PDOException
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Row ORDER BY location_name, name' at line 1 (42000)
at file /var/www/html/racktables/wwwroot/inc/database.php, line 4009

/var/www/html/racktables/wwwroot/inc/database.php:4009 execute(Array
(
)
)
/var/www/html/racktables/wwwroot/inc/database.php:464 usePreparedSelectBlade('SELECT Row.id, Row.name, Row.location_id, Row.location_name, (select count(Rack.id) from Rack where row_id = Row.id) as rackc FROM Row ORDER BY location_name, name', Array
(
)
)
/var/www/html/racktables/wwwroot/inc/interface.php:444 listCells('row')
/var/www/html/racktables/wwwroot/index.php:35 renderRackspace(NULL)
Error info:
Array
(
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Row ORDER BY location_name, name' at line 1
)
Parameters:
GET
(array)
page rackspace
POST
(array)
COOKIE
(array)
PHPSESSID 1mrssio3tifm1be2lccnbccfq3
SL_G_WPT_TO ru
SL_GWPT_Show_Hide_tmp 1
SL_wptGlobTipTmp 1


Please, give me advise, how can I fix it!
TagsNo tags attached.

Relationships

duplicate of 1909 closed Pdo exception: PDOException 

Activities

Sergey_yamaha

Sergey_yamaha

2019-10-17 22:10

reporter   ~0003997

Problem is solved
viperbmw69

viperbmw69

2019-10-17 23:49

reporter   ~0004001

Close the issue if solved please. :)

Issue History

Date Modified Username Field Change
2019-10-17 21:50 Sergey_yamaha New Issue
2019-10-17 22:10 Sergey_yamaha Note Added: 0003997
2019-10-17 23:49 viperbmw69 Note Added: 0004001
2019-10-18 07:31 Sergey_yamaha Status new => closed
2019-10-18 07:31 Sergey_yamaha Resolution open => fixed
2019-11-11 21:21 infrastation Relationship added duplicate of 1909