View Issue Details

IDProjectCategoryView StatusLast Update
1941RackTablesIPv4/IPv6/SLBpublic2019-11-11 21:29
Reporterank217Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.21.3 
Target Version0.21.4Fixed in Version0.21.4 
Summary1941: after upgrading MySQL DB from 5.7.22 to 8.0.18 I get errors on Racktables database.ini file
Descriptionafter upgrading MySQL DB from 5.7.22 to 8.0.18 I get errors on Racktables database.ini file

When clicking on Racktables icon I get error below in browser ;

PDOException
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Row ORDER BY location_name, name' at line 1 (42000)
at file /opt/gse/web2/httpd-2.4.41/htdocs/racktables/wwwroot/inc/database.php, line 4010

/opt/gse/web2/httpd-2.4.41/htdocs/racktables/wwwroot/inc/database.php:4010 execute(Array
(
)
)
/opt/gse/web2/httpd-2.4.41/htdocs/racktables/wwwroot/inc/database.php:465 usePreparedSelectBlade('SELECT Row.id, Row.name, Row.location_id, Row.location_name, (select count(Rack.id) from Rack where row_id = Row.id) as rackc FROM Row ORDER BY location_name, name', Array
(
)
)
/opt/gse/web2/httpd-2.4.41/htdocs/racktables/wwwroot/inc/interface.php:444 listCells('row')
/opt/gse/web2/httpd-2.4.41/htdocs/racktables/wwwroot/index.php:35 renderRackspace(NULL)
Error info:
Array
(
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Row ORDER BY location_name, name' at line 1
)
Parameters:
GET
(array)
page rackspace
POST
(array)
COOKIE
(array)
_ga GA1.2.146038784.1571247057
_gcl_au 1.1.1086124814.1571247057
fivehd_id b12289ff-163d-438f-ad59-67b71fdd3991
_fbp fb.1.1571247057450.1374484927
_hjid 68fde711-f890-4cab-b51f-17d2be894e65
PHPSESSID 18a2e112657226dfbc5016f58ec3af06
Steps To Reproduceoccurs consistently ever time I hit Racktables icon, no difference in database.ini from version 0.21.2 and 0.21.3

Additional Informationt
TagsNo tags attached.

Relationships

duplicate of 1909 closed Pdo exception: PDOException 

Activities

infrastation

infrastation

2019-11-11 21:29

administrator   ~0004003

If you do not want to wait until the next stable release is out, here is a patch you can apply directly: https://code.racktables.org/racktables/patch/fc92cbc3ebea0066447c96a3707183d86b7dea0e

Issue History

Date Modified Username Field Change
2019-11-11 18:49 ank217 New Issue
2019-11-11 21:22 infrastation Relationship added duplicate of 1909
2019-11-11 21:29 infrastation Status new => closed
2019-11-11 21:29 infrastation Resolution open => duplicate
2019-11-11 21:29 infrastation Fixed in Version => 0.21.4
2019-11-11 21:29 infrastation Target Version => 0.21.4
2019-11-11 21:29 infrastation Note Added: 0004003