View Issue Details

IDProjectCategoryView StatusLast Update
2021RackTablesdefaultpublic2021-04-06 15:22
Reporterfdupont Assigned Toinfrastation  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.21.4 
Target Version0.22.0Fixed in Version0.22.0 
Summary2021: Permissions on op_deleteObject and typeid do not work
DescriptionHi,

I tried to set a permissions that disallow to delete objects except for some object types. It appears {$typeid_xxxx} is not parsed by the permission system.

\fab
Steps To Reproduce1.Set the following permission

allow {$op_deleteObject} and {$typeid_1504}
deny {$op_deleteObject}

2. Create a VM object
3 .Try to delete the object

This returns a "Operation not permitted" message.
TagsNo tags attached.

Activities

infrastation

infrastation

2021-04-04 23:34

administrator   ~0004271

I confirm this reproduces as described and looks like a bug, but have not fully established the reason for this.
infrastation

infrastation

2021-04-05 18:11

administrator   ~0004273

I have identified the root cause of this bug.
infrastation

infrastation

2021-04-06 15:22

administrator   ~0004275

The next release will include the bugfix, thank you for the bug report.

Related Changesets

RackTables: master b028a8f4

2021-04-06 15:07:39

infrastation

Details Diff
evaluate {$op_deleteObject} in the right context

op=deleteObject used to live at depot-addmore, which resulted in
fixContext() not adding the current object into the context. Move the
operation to object-edit and fix Mantis issue 2021.

* renderEditObjectForm(): When calling getOpLink(), specify only "op"
and leave the rest to be derived.
* deleteObject(): After deleting the object redirect to depot-addmore
via buildRedirectURL().
Affected Issues
2021

Issue History

Date Modified Username Field Change
2021-04-02 13:22 fdupont New Issue
2021-04-04 23:34 infrastation Status new => acknowledged
2021-04-04 23:34 infrastation Note Added: 0004271
2021-04-05 18:11 infrastation Assigned To => infrastation
2021-04-05 18:11 infrastation Status acknowledged => assigned
2021-04-05 18:11 infrastation Target Version => 0.22.0
2021-04-05 18:11 infrastation Note Added: 0004273
2021-04-06 15:20 infrastation Changeset attached => RackTables master b028a8f4
2021-04-06 15:22 infrastation Status assigned => closed
2021-04-06 15:22 infrastation Resolution open => fixed
2021-04-06 15:22 infrastation Fixed in Version => 0.22.0
2021-04-06 15:22 infrastation Note Added: 0004275