View Issue Details

IDProjectCategoryView StatusLast Update
0001579RackTablesdefaultpublic2016-01-30 04:07
ReporterwilliamwAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
PlatformLinuxOSCentOSOS Version6.5
Product Version0.20.10 
Target VersionFixed in Version 
Summary0001579: Logout Loop after initial installation
DescriptionAfter logging in for the first time, creating a new user and then clicking to logout, the following happens:

Username/Password prompt is displayed.
It will take neither the admin credentials nor the new user credentials.
Clicking cancel is the only option. Upon doing to it displays, "This system requires authentication. You should use a username and a password." with the page being, "index.php?logout"

Manually going to index.php at this point displays an "access denied" page with the message, "Click here to logout."

Doing so displays the Username/Password prompt which won't accept either username or password and the loop begins again. Even when switching to a CHrome incognito window this issue persists.

The username and passwords do work when logging in from another computer.
Steps To ReproducePerform fresh installation.

Update timezone to: America/Los_Angeles

Create new user.

Click Logout link.
Additional InformationThere are no PHP or apache errors or warnings in the logs when this happens.
TagsNo tags attached.

Relationships

duplicate of 0000496 closedinfrastation logout did not work as expected 

Activities

williamw

williamw

2016-01-29 22:20

reporter  

adoom42

adoom42

2016-01-30 04:07

administrator   ~0003111

The logout function could use improvement. Closing because this is covered in another issue.

Docs which may help you:

http://wiki.racktables.org/index.php/FAQ#How_do_I_log_out_.28and_log_in_after_that.3F.29

http://wiki.racktables.org/index.php/RackTablesAdminGuide#logging_out

Issue History

Date Modified Username Field Change
2016-01-29 22:20 williamw New Issue
2016-01-29 22:20 williamw File Added: 2016-01-29 13_13_20-RackTables_ access denied.png
2016-01-30 04:05 adoom42 Relationship added duplicate of 0000496
2016-01-30 04:07 adoom42 Note Added: 0003111
2016-01-30 04:07 adoom42 Status new => closed
2016-01-30 04:07 adoom42 Resolution open => duplicate